GWARANTOWANE TERMINY
Jesteś tutaj: strona głównastrefa wiedzyNauka języków obcych z Excelem
MENU

Nauka języków obcych z Excelem


Kategoria: Kurs Excel, Samouczek Excel
16Mar

Program Excel może nam pomóc nie tylko w codziennej pracy zawodowej, ale także w codziennych czynnościach np. w nauce języków obcych. W artykule opracowanym przez trenerkę Cognity, Panią Barbarę Skowrońską pokażemy, jak przygotować arkusz kalkulacyjny tak, aby pomóc sobie w nauce. 

Naszym zadaniem będzie przygotowanie arkusza, w którym Excel wybierze losowo słowo z przygotowanego przez nas słownika i oceni, czy wpisana przez użytkownika odpowiedź jest poprawna.

MS Excel: jak przygotować arkusz do nauki języka angielskiego?

W wybranym zakresie np. A1:B16 umieścimy słownik z piętnastu słówek, a komórkach np. E3:G4 nasze narzędzie do nauki.

W komórce E4 będzie losowany obcy wyraz, w F4 będziemy wybierać jego polski odpowiednik z listy, a w G4 Excel oceni poprawność odpowiedzi.

MS Excel: funkcje INDEKS i LOS.ZAKRES

W komórce E3 napiszemy formułę losującą słowo. Zbudujemy ją z funkcji INDEKS i LOS.ZAKRES (rys.1)

Formuła wybiera losowo numer wiersza z zakresu A2:A16 od 1 do 15. Po każdym przeliczeniu arkusza 

rys 1

Rysunek 1

(lub naciśnięciu klawisza F9) zwraca słowo znajdujące się w wylosowanym wierszu, w kolumnie A.

Wybierając klawisz F9 dostaniemy w komórce F3 nowe wylosowane słowo.

W komórce G4 będziemy wpisywać, lub wybierać z listy właściwe znaczenie wylosowanego wyrazu.

MS Excel: nauka z pomocą funkcją JEŻELI i WYSZUKAJ.PIONOWO

Chcemy, by Excel porównał wybraną odpowiedź ze słownikiem i ocenił, czy jest poprawna.

Można to zrobić za pomocą funkcji JEŻELI i WYSZUKAJ.PIONOWO, ale… po wpisaniu i zatwierdzeniu klawiszem enter odpowiedzi, arkusz zostanie przeliczony i zostanie wylosowane nowe słowo. W tej sytuacji poprawna odpowiedź może pojawić się tylko przypadkowo.

Jak zatem utrwalić rezultat działania funkcji? 

Zarejestrujemy makro, które po wylosowaniu słowa  kopiuje zawartość komórki  E3 i wklei ją jako wartość do komórki E4, a po przeliczeniu arkusza usunie poprzednią odpowiedź z komórki F3.

Makra w MS Excel: rejestracja

Włączmy rejestrowanie makra—zakładka Developer/grupa Kod/Zarejestruj makro (rys.2)

rys 2

Rysunek 2

W oknie Rejestrowanie makra (rys. 3) nadajemy mu nazwę, np. „Losowanie”.

rys 3

Rysunek 3

  • naciskamy F9,
  • wybieramy komórkęE3,
  • kopiujemy ją (Ctrl+C) i w komórce E4 wklejamyjako wartość (rys 4),

rys 4

Rysunek 4

  • wciskamy klawisz ESC,
  • przechodzimy do komórki obok (klawisz TAB) i wybieramy klawisz DEL,
  • zatrzymujemy rejestrację makra (rys.5)

rys 5

Rysunek 5

Teraz wstawiamy dowolny kształt i przypiszemy do niego nasze makro (rys.6 i rys.7)

rys 6

Rysunek 6

 

rys 7

Rysunek 7

Utworzony przycisk możemy sformatować i dodać tekst np. „Losuj wyraz”.

rys 8

Rysunek 8

Pozostaje nam stworzenie listy wyboru odpowiedzi w komórce F4. (Karta: Dane/grupa: Narzędzia danych/Poprawność danych) jak na rys.9

rys 9

Rysunek 9

Na zakończenie, w komórce G4 piszemy formułę sprawdzającą poprawność wybranej odpowiedzi: 

=JEŻELI(CZY.PUSTA(F4);"";JEŻELI(F4=WYSZUKAJ.PIONOWO(E4;Słownik!A2:B16;2;0);"Dobrze";"Źle"))

Przygotowany test będzie bardziej użyteczny, jeśli słownik znajdzie się w osobnym arkuszu.

Zaznaczymy go zatem; wytniemy (ctrl+X) i wkleimy do Arkusza2. Warto też zabezpieczyć komórki zawierające formuły (ochrona arkusza), dodać nagłówki i sformatować całość. 

Autorem artykułu jest trener Cognity Barbara Skowrońska

 

Licencja Creative Commons
Nauka języków obcych z Excelem by Cognity is licensed under a Creative Commons Uznanie autorstwa-Użycie niekomercyjne 4.0 Międzynarodowe License.

Wybrani Klienci:

Ten serwis używa plików cookies. Brak zmiany ustawień przeglądarki oznacza zgodę na ich używanie.
Więcej informacji o plikach cookies znajdziesz tutaj
Kliknij ZGADZAM SIĘ, aby ta informacja nie wyświetlała się ponownie
Cognity.pl